В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vika2074
vika2074
21.09.2022 16:16 •  Информатика

Нужно написать программу на паскале обязательно используя цикл for. программа вычисляет среднее арифметическое положительных элементов ряда чисел. каждый элемент ряда вычисляется по формуле: (12*k-21)/3, где k--номер элемента в ряду. всего элементов--необходимо спросить.

Ответ:
ladaponomareva
ladaponomareva
26.08.2020 09:56
Var K,n:integer;
S:real;
Begin
n:=0;
Write('K = ');ReadLn(K);
For K:= 1 to K do
    Begin
    Write((12*K-21)/3,' ');
    if (12*K-21)/3 > 0 then
       Begin
       S:=S+(12*K-21)/3;
       n:=n+1
       End;
    End;
WriteLn;
Write('Sr = ',S/n)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?