Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
dayana20072
17.06.2021 00:06 •
Информатика
Составьте программу(паскаль) для определения количества цифр в записи произвольного натурального числа. сейчас проходим while, судя по всему его и надо использовать.
Ответ:
Geimer200
05.10.2020 19:16
Var n,p,k:integer;
begin
readln (n);
p:=n;
while p<> 0 do begin
k:=k+1;
p:=p div 10;
end;
writeln ('k=',k);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
albina8427
04.09.2022 03:19
Найди результат кода. s= регистр print( s= ,s) print( s[0:5]= ,s[0:5]); print( s[-5:]= ,s[-5:]); print( max(s)= ,max(s))...
Fernier
29.03.2023 17:20
Кто понимает ! -распечатать в столбик таблицу умножения на 7 . составить программу. я сделала это так,оказалось не правильно : program tablica; var i: integer; begin i: =1; while(i...
Зефирка78
14.09.2022 11:39
Нужно написать программу ( в паскале) в результате выполнения который большее из двух чисел заменяется числом ему противоположным ....
SaviRay
14.09.2022 11:39
Отгадать правила кодирования 5 6 12 23 123 234 77 555...
kaban229
14.09.2022 11:39
1. в электронных таблицах осуществить копирование формулы, содержащей относительные ссылки, из активной ячейки с1 в ячейку d2 и в ячейку ез. какие формулы будут в этих ячейках?...
nastenadanil2698
12.01.2021 23:19
Количество целых чисел от 60(8) до 40(16)...
Olyecvh
16.06.2021 14:22
мощность алфавита равна 256 символов каким будет обьем информации в тексте состоящий из 100 символов...
Mary17ice
30.07.2020 09:49
С решением Перевести число 1201 из десятичной в одинадцатеричную систему счисления 2. Перевести число 1011111101 из двоичной в десятичную систему счисления 3. Перевести число 0.875...
wwwghg
12.10.2022 08:09
-Перевести 41 943 040 бит в мегабайты -Перевести 4,5 мегабайта в биты- Перевести 0,5 гигабайта в байты...
Natasha1678
30.12.2021 06:14
3. Найдите наименьшее из чисел А, В, С и D, записанных в различных системах счисления, если A = 10234 B = 4718 C = 731% D = 10010102...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
readln (n);
p:=n;
while p<> 0 do begin
k:=k+1;
p:=p div 10;
end;
writeln ('k=',k);
end.