В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
olyamin0
olyamin0
23.04.2020 16:07 •  Информатика

Составить программу на паскаль из массива р, содержащего 10 элементов, сформировать массив н по правилу: н(к)=i/p(к), (к -чётные), н(к)=р(к)+к, (к - нечётные) в массиве, содержащем 10 элементов, нечётным элементам присвоить значения квадратов их индексов. в массиве, содержащем 10 элементов, напечатать индекс последнего из элементов, равных 0.

Ответ:
ZVer00711
ZVer00711
05.10.2020 19:13
{Из массива Р, содержащего 10 элементов, сформировать массив Н по правилу:Н(к)=I/P(к), (к -чётные), Н(к)=Р(к)+к, (к - нечётные)В массиве, содержащем 10 элементов, нечётным элементам присвоить значения квадратов их индексов.В массиве, содержащем 10 элементов, напечатать индекс последнего из элементов, равных 0.}var P:array[1..10] of integer; H:array[1..10] of real;i:integer;index1, index2:integer;
begin

  writeln('Введите элементы массива P: ');  for i:=1 to 10 do  begin  readln(P[i]);  end; writeln; writeln('Массив P: ');  for i:=1 to 10 do  begin  write(' '+P[i]+' ');  end;
  writeln;  writeln('Массив H: ');   for i:=1 to 10 do  begin   if (i mod 2 = 0) then  begin  H[i]:=1/P[i];  end;   if (i mod 2 <> 0) then  begin  H[i]:=P[i]+i;  end;   end;  for i:=1 to 10 do  begin  write(' '+H[i]+' ');  end;   writeln; writeln;  writeln('Нечётным элементам присваиваем значения квадратов их индексов');  for i:=1 to 10 do  begin  if (i mod 2 <> 0) then  P[i]:=i*i;  end;   for i:=1 to 10 do  begin  if (i mod 2 <> 0) then  H[i]:=i*i;  end;  writeln('Массив P: ');  for i:=1 to 10 do  begin  write(' '+P[i]+' ');  end;
  writeln;  writeln('Массив H: ');  for i:=1 to 10 do  begin  write(' '+H[i]+' ');  end;   writeln; writeln; writeln('Напечатать индекс последнего из элементов, равных 0'); for i:=1 to 10 do  begin  if (P[i] = 0) then  index1:=i;  end;  writeln;  writeln('Индекс для массива P: '+index1);    for i:=1 to 10 do  begin  if (H[i] = 0) then  index2:=i;  end;  writeln;  writeln('Индекс для массива H: '+index2);  end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?