В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Rosalin1
Rosalin1
17.11.2022 05:50 •  Информатика

Напишите программу на языке программирования си с клавиатуры 2 прямые. определить их параллельность

Ответ:
Ntt1
Ntt1
05.10.2020 18:56
#include <stdio.h>

float vychislenie(float X1, float X2, float Y1, float Y2);
float vqvod_rezultatov(float K1,float K2);

int main(){
    float X1=0,X2=0,X3=0,X4=0;   
    float Y1=0,Y2=0,Y3=0,Y4=0;   
    float K1=0, K2=0;
   
    printf("Vvedite koordinaty pervoj prjamoj cherez probel (X1 Y1 X2 Y2): ");
    scanf("%f %f %f %f", &X1, &Y1, &X2, &Y2);   
    printf("\nA(%.1f ; %.1f), B(%.1f ; %.1f)\n\n", X1, Y1, X2, Y2);   
    printf("Vvedite koordinaty vtoroj prjamoj cherez probel (X1 Y1 X2 Y2): ");  
    scanf("%f %f %f %f", &X3, &Y3, &X4, &Y4);   
    printf("\nC(%.1f ; %.1f), D(%.1f ; %.1f)\n", X3, Y3, X4, Y4);

    K1=vychislenie(X1,X2,Y1,Y2);   
    K2=vychislenie(X3,X4,Y3,Y4);   
    vqvod_rezultatov(K1, K2);

return 0;
}

float vychislenie(float X1, float X2, float Y1, float Y2){

    float K=0;   
    K=((Y2-Y1)/(X2-X1));

return K;
}

float vqvod_rezultatov(float K1, float K2){
   
    printf("\nKoefficient K1 = %.2f\n", K1);   
    printf("Koefficient K2 = %.2f\n", K2);
   
       if(K1==K2){       
                   printf("\nPrjamye parallelny\n");   
              }else{       
                     printf("\nPrjamye ne parallelny\n");   
               }
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?