В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Напишите программу на питоне, . программа получает на вход строку и символ. используя метод напишите программу, которая выводит все позиции, где встречается этот символ.

Ответ:
Музалевская
Музалевская
20.08.2020 15:36
S = input('Строка: ')
c = input('Символ: ')[0]
o = []
p = 0
while True:
    r = s.find(c, p)
    if r == -1:
        break
    else:
        o.append(str(r))
        p = r + 1
print('Позиции:', ', '.join(o))
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?