В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
pachev
pachev
16.04.2023 22:37 •  Информатика

Напишите программу в паскале abc, и нарисуйте к ней блок-схему. вводится массив из 15 элементов,нужно определить сколько эл. массива будут между его макс и миним. элементом.

Ответ:
margo2200078
margo2200078
05.10.2020 18:17
Var
i,max,min,res,maxi,mini:integer;
a: array [1..15] of integer;
begin
writeln('Введите числа');
for i:=1 to 15 do
read(a[i]);
max:=a[1];
min:=a[1];
for i:=1 to 15 do
begin
if max<a[i] then begin
max:=a[i];
maxi:=i;
end;
if min>a[i] then begin
min:=a[i];
mini:=i;
end;
end;
if maxi>mini then
res:=maxi-mini
else
res:=mini-maxi;
res:=res-2;
writeln('между максимум и минимум = ', res, ' элементов');
end.
Напишите программу в паскале abc, и нарисуйте к ней блок-схему. вводится массив из 15 элементов,нужн
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?