В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
JoiLok
JoiLok
07.10.2021 12:56 •  Информатика

Массив из 10 элементов заполняется целыми числами. составьте программу, которая вычисляет среднее арифметическое элементов, заканчивающихся на цифру 7

Ответ:
tflash191
tflash191
05.10.2020 18:04
Const
K = 10;
Var
A:array[1..K] of integer;
S,i,n:integer;
Begin
S:=0;
n:=0;
Write('Исходный массив: ');
For i:= 1 to K do
    Begin
    A[i]:=random(201)-100;
    Write(A[i],' ');
    if A[i] mod 10 = 7 then
       Begin
       S:=S+A[i];
       n:=n+1
       End;
    End;
WriteLn;
if n = 0 then WriteLn('В массиве нет элементов, оканчивающихся на семь')
else WriteLn('Среднее арифметическое элементов, оканчивающихся на семь: ',S/n);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?