В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
1gs1221
1gs1221
10.03.2023 17:21 •  Информатика

1. определите, сколько элементов массива a равны заданному значению x. 2. вычислить произведение всех элементов массива a, которые делятся на 3. 3. определите в массиве a номер первого элемента, равного x.

Ответ:
kashamovasha
kashamovasha
05.10.2020 18:00
Const
K = 13;
Var
A:array[1..K] of integer;
i,n,X:integer;

Begin
Write('X = ');ReadLn(X);
Write('Исходный массив: ');
For i:= 1 to K do
    Begin
    A[i]:=random(21)-10;
    Write(A[i],' ');
    End;

n:=0;
For i:= 1 to K do
    if A[i]=X then n:=n+1;
WriteLn;
WriteLn(n,' - кол-во элементов, равных ',X);
End.

Const
K = 13;
Var
A:array[1..K] of integer;
i:integer;
P:real;

Begin
P:=1;
Write('Исходный массив: ');
For i:= 1 to K do
    Begin
    A[i]:=random(21)-10;
    Write(A[i],' ');
    if A[i] mod 3 = 0 then P:=P*A[i]
    End;
WriteLn;
WriteLn('Произведение элементов,кратных трём: ',P)
End.

Const
K = 13;
Var
A:array[1..K] of integer;
i,X:integer;
Begin
Write('X = ');ReadLn(X);
Write('А: ');
For i:= 1 to K do
    Begin
    A[i]:=random(21)-10;
    Write(A[i],' ');
    End;
WriteLn;
i:=0;
Repeat
i:=i+1;
Until (A[i]=X)or(i=K);
if A[i]=X then WriteLn(i)
else WriteLn('Таких элементов нет')
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?