В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
denmalyshevs
denmalyshevs
14.06.2022 10:21 •  Информатика

1.записать на языке паскаль выражение: | x² - 20 | / cos y + 5x √y 2.чему равны значения переменных t и r после исполнения фрагмента программы: t : =1 if r > 10then r: =r+1; t: =8; a) (1,56) при r = 17; б) (2б) при r = 9. 3.сколько раз выполнится цикл и что будет на экране после исполнения фрагмента программы. for i: = - 10 to - 9 do begin k: =i; write(k); end. 4.магазин установил скидки покупателям за сумму покупок: от 5 тысяч руб. - 0.5 % от 10 тысяч руб. - 2 %,начиная от 20 тысяч руб. - 5 % сяч з а) составить программу,которая для введенного целого числа ( количества тысяч за покупку) выводит на экран процент скидки. б) составить программу,которая для 10 введенных с клавиатуры чисел (количества тысяч руб. за покупку 10 покупателей) выводит на экран процент скидки до каждого.

Ответ:
elmirayanbukov
elmirayanbukov
02.08.2020 22:58
1)
abs(x*x - 20) / Cos(y) + 5*x*sqrt(y)

2)
t :=1
if r >10then r:=r+1;t:=8;

a)
При r=17 условие выполняется, значит r увеличится на единицу.

Команды не связаны операторными скобками (begin r:=r+1;t:=8; end),
поэтому t:=8; выполнится безусловно.

r=18;  t=8;

б)
При r = 9 условие не выполняется, поэтому значение r останется неизменным.

r = 9;  t = 8;

3)
for i:= - 10 to - 9 do
begin k:=i;write(k);end.

Цикл For не выполнится ни разу. На экран не будет выведено ничего.

Цикл "For i:= A to B do" выполняется B-A+1 раз, при условии, что B>=A.
В нём значение i меняется от A до B, с каждой итерацией прибавляется единица.

Цикл "For i:= A downto B do" выполнится A-B+1 раз, при условии, что A>=B
В нём значение i тоже меняется от A до B, но с каждой итерацией от i отнимается единица.

4)
а)
Var
A:integer;
Begin
Write('Введите сумму покупок: ');ReadLn(A);
if A<5 then Write('Скидка не предоставляется')
else if (A>=5)and(A<10) then Write('Скидка: 0.5%')
     else if (A>=10)and(A<20) then Write('Скидка: 2%')
          else Write('Скидка: 5%')
End.

б)

Var
A,i:integer;
Begin
For i:= 1 to 10 do
Begin
Write('Введите сумму покупок: ');
ReadLn(A);
if A<5 then WriteLn('Скидка не предоставляется')
else if (A>=5)and(A<10) then WriteLn('Скидка: 0.5%')
     else if (A>=10)and(A<20) then WriteLn('Скидка: 2%')
          else WriteLn('Скидка: 5%')
End
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?