В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
jubatkanovajd
jubatkanovajd
19.05.2020 20:08 •  Информатика

Синформатикой, напишите программу на vb.net два натуральных числа называются дружественными, если каждое из них равно сумме всех делителей другого (само и другое число в качестве делителя не рассматривается). найти все пары дружественных чисел, которые меньше n (n вводится с клавиатуры) пример дружественных чисел: 220 и 284, т.к. сумма делителей 220 = 1+2+4+5+10+11+20+22+44+55+110=284 сумма делителей 284 = 1+2+4+71+142=220

Ответ:
64даня1166
64даня1166
05.10.2020 17:25
Код на VBScript - проверялся, работает

Function SumOfDividers(ByVal num)
    SumOfDividers = 0

    for i = 1 to num - 1
        if num mod i = 0 then SumOfDividers = SumOfDividers + i
    next
End Function

Sub Zadanie23317569(ByVal n)
    for i = 2 to n
        k = SumOfDividers(i)
        if SumOfDividers(k) = i then Msgbox i & " " & k
    next
End Sub

Zadanie23317569 300

Код на VB.Net  - исправление как догадалась, не проверялось

Sub Main(ByVal n)
    Dim i As Integer
    Dim k As Integer

    for i = 2 to n
        k = SumOfDividers(i)
        if SumOfDividers(k) = i then Console.WritelLine(i & " " & k)
    next
End Sub

Function SumOfDividers(ByVal num As Integer) As Integer
    Dim i As Integer
    SumOfDividers = 0

    for i = 1 to num - 1
        if num mod i = 0 then SumOfDividers = SumOfDividers + i
    next
End Function
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?