В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
maksimiksanov
maksimiksanov
28.12.2020 21:00 •  Информатика

Написать программу в паскале, которая находит максимальное нечетное отрицательное число среди чисел ,уже записанных в готовом текстовом файле, и выводит результат в другой файл.

Ответ:
луя3
луя3
05.10.2020 16:38
Program n1;
var a,max: integer;
f: text;
begin
assign(f,'input.txt');
reset(f);
max:=0;
while not eof(f) do
begin
read(f,a);
if (abs(a)>max) and (a<0) and (a mod 2 <>0) then max:=a;
end;
close(f);
assign(f,'output.txt');
rewrite(f);
write(f,max);
close(f);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?