В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
lera5471
lera5471
26.01.2023 04:37 •  Информатика

Написать программу по : автомат получает на вход четырехзначное десятичное число. по полученному числу строится новое десятичное число по следующим правилам. 1. вычисляются два числа -сумма двух старших и сумма двух младших разрядов. 2. полученные два числа записываются друг за другом в порядке невозрастания (без разделителей).

Ответ:
ттсссс
ттсссс
05.10.2020 16:25
Var
A,B:integer;
Begin
ReadLn(A);
B:=(A div 1000) + ((A div 100) mod 10);
A:=((A div 10) mod 10)+ (A mod 10);
if A>=B then Write(B,A)
else if B>=A then Write(B,A)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?