В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
macha2017
macha2017
15.02.2023 11:17 •  Информатика

Напишите программу в paskalabc , которая в последовательности натуральных чисел определяет максимальное чётное число. программа получает на вход количество чисел в последовательности , а затем сами числа . в последовательности всегда имеется чётное число. количество чисел не превышает 1000. введённые числа не превышают 30000.программа должна вывести одно число-максимальное чётное число . пример работы программы : входные данные : 3,10,99,42 выходные данные: 42

Ответ:
belover
belover
05.10.2020 16:21
Var
N,A,M:word;
Begin
Read(N);
M:=0;
For N:=1 to N do
    Begin
    Read(A);
    if (A>M)and(A mod 2 = 0) then M:=A;
    End;
Write(M)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?