В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
VerinaNice
VerinaNice
19.04.2022 20:31 •  Информатика

Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). размер массива заранее неизвестен. исходные данные записаны в файл input.txt , отсортированный массив нужно вывести в файл output.txt . входные данные все элементы массива записаны по одному в каждой строке входного файла input.txt . ввод завершается числом 0. выходные данные программа должна вывести в файл output.txt все элементы отсортированного массива в одной строке, разделив их пробелами. примеры входные данные 5 1 -4 -2 3 0 выходные данные -4 -2 1 3 5

Ответ:
дарья1643
дарья1643
09.08.2020 18:44
Program n1;
type z = array of integer;
var a: z;
i,n,j,buf,t: integer;
f: text;
begin
assign(f,'input.txt');
reset(f);
n:=1;
t:=0;
while true do
begin
readln(f,t);
if(t<>0) then
begin
setlength(a,n);
a[n-1]:=t;
end else break;
n:=n+1;
end;
close(f);
for i:=0 to n-3 do
for j:=i+1 to n-2 do
if a[i]>a[j] then begin
buf:=a[i];
a[i]:=a[j];
a[j]:=buf;
end;
assign(f,'output.txt');
rewrite(f);
for i:=0 to n-2 do write(f,a[i],' ');
close(f);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?