В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
кульпан1
кульпан1
05.02.2023 08:13 •  Информатика

Составьте программу к следующей : ученик начал решать данного урока программирования, когда электронные часы показывали h1 часов и min1 минут, а закончил, когда было h2часов и min2 минут. составьте программу, позволяющую определить, сколько времени (в часах и минутах) ученик решал эти .

Ответ:
SolDPriCe
SolDPriCe
05.10.2020 16:06
Используется время одних суток.
var h1,min1,h2,min2,h,min,m:integer;
begin
write('h1, m1: ');
readln(h1,min1);
write('h2, m2: ');
readln(h2,min2);
m:=(h2*60+min2)-(h1*60+min1);
h:=m div 60;
min:=m mod 60;
writeln('h = ',h,' min = ',min);
end.

Пример:
h1, m1: 1 20
h2, m2: 3 15
h = 1 min = 55
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?