В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
VladislavaForster
VladislavaForster
12.12.2020 11:24 •  Информатика

Решить в pascal abc написать программу, которая вычисляет факториал числа, введенного с клавиатуры. (факториал числа n называется произведение целых чисел от 1 до n. например, факториал числа 1 равен 1, а числа 8 – 40320.) вычисление факториала. введите число, факториал которого надо вычислить -> 7 факториал 7 равен 5040.

Ответ:
lubas143
lubas143
14.08.2020 19:20
Var
N:integer;
F:BigInteger:=1;
Begin
Write('N = ');Read(N);
For N:= 1 to N do
    F:=F*N;
Write(N,'! = ',F)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?