В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
airmenplay
airmenplay
07.07.2021 09:14 •  Информатика

Вмассиве из 10 целых чисел подсчитать количество элементов меньше чем среднее арифметическое минимального н максимального элементов. написать программу в delphi7

Ответ:
настя7603
настя7603
05.10.2020 15:12
  var mas:array[0..9] of integer; 
 i,max,min,k:integer;
  arifm:real;
begin 
k:=0;
arifm:=0; 
 Randomize;
  for i:=0 to 9 do
  mas[i]:=Random(15);
  for i:=0 to 9 do 
 write(mas[i],'  '); 
 {poisk max} 
   max:=mas[0];
     for i:=1 to 9 do 
    if max<mas[i] then 
    max:=mas[i]; 
     {poisk min} 
   min:=mas[0]; 
   for i:=1 to 9 do 
    if min>mas[i] then 
    min:=mas[i];
     arifm:=(max+min)/2; 
    writeln('max: ',max); 
   writeln('min: ',min); 
    writeln('arifm: ',arifm:0:3); 
   for i:=0 to 9 do 
   if mas[i]<arifm then 
    inc(k); 
   writeln('k: ',k);
  readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?