В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ларводаны
ларводаны
18.12.2022 04:08 •  Информатика

Написать программу которая сумму всех цифр пятизначного числа х который вводится с клавиатуры и определит заканчивается ли эта сумма на три и четная эта сумма или нет информатика 8 класс

Ответ:
nastuastar12
nastuastar12
05.10.2020 15:07
Program n1;
var a: longint;
procedure sumdig(var x: longint);
var s:longint;
begin
s:=0;
while ( x<>0 ) do
begin
s := s + (x mod 10);
x := x div 10;
end;
if s mod 10=3 then writeln('оканчивается на 3')
else writeln('не оканчивается на 3');
if s mod 2=0 then writeln('четная') else
writeln('нечетная');
end;
begin
writeln('введите целое число');
readln(a);
sumdig(a);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?