В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
aiha4567
aiha4567
01.05.2022 01:03 •  Информатика

Составить программу.заранее ! дано натуральное число n.найти произведение нечетных цифр числа. верно ли, что произведение числа является трехзначным числом.

Ответ:
victoriareih
victoriareih
23.05.2020 23:24

program msd;
uses crt;
var a,l,proiz,b,i:LONGINT;
begin
clrscr;
readln(a);
proiz:=1;
while true do
begin
l:=a mod 10;
a:= a div 10;
if odd(l) = true then
proiz:=proiz*l
else
b:=b+1;
i:=i+1;
if a = 0 then break;
end;
if b = i then writeln('0')
else
writeln(proiz);
if (proiz>99) and (proiz<1000) then writeln('Da')
else writeln('Net');
ReADKeY;
eND.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?