В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Mrx7777
Mrx7777
18.07.2022 03:11 •  Информатика

Напишите программу, которая находит все символы в символьной строке, которые встречаются только один раз. входные данные на вход программы подаётся символьная строка. выходные данные программа должна вывести все символы, которые встречаются в строке только один раз, в порядке возрастания их ascii-кодов. если таких символов нет, нужно вывести слово 'no'. примеры входные данные asd12ad2 выходные данные 1s pascal abc 1.8 с использованием множеств

Ответ:
Вячеслав991
Вячеслав991
02.08.2020 21:28
Var uniq: Set of Char;
    used: Set of Char;
    s: string;
    i: integer;
    done: boolean;
    c: char;
begin
uniq := [];
used := [];
readln(s);

for i := 1 to length(s) do
  if not (s[i] in used) then
  begin
    include(uniq, s[i]);
    include(used, s[i]);
  end
  else
  begin
    exclude(uniq, s[i]);
  end;

done := False;
for c := #0 to #255 do
  if (c in uniq) then
  begin
    done := True;
    write(c);
  end;

if not done then
  write('NO');

writeln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?