В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Topergggg
Topergggg
26.11.2022 08:07 •  Информатика

Друзья, напишите программу pascal. вводится числитель и знаменатель обыкновенной дроби, сократить ее. через procedure .

Ответ:
Непатриот
Непатриот
05.10.2020 14:41
// PascalABC.NET 3.2, сборка 1387 от 17.02.2017
// Внимание! Если программа не работает, обновите версию!

function Gcd(a,b:integer):integer; // НОД
begin
  while b<>0 do begin a:=a mod b; Swap(a,b) end;
  Result:=a
end;

procedure RedFrac(var a,b:integer); // сокращение дроби
begin
  var sgna:=sign(a); // мы должны учитывать знак!
  var sgnb:=sign(b); // мы должны учитывать знак!
  a:=abs(a); b:=abs(b);
  var d:=Gcd(a,b);
  a:=(a div d)*sgna; b:=(b div d)*sgnb
end;

begin
  var p,q:integer;
  Write('Введите числитель и знаменатель: '); Read(p,q);
  RedFrac(p,q);
  Writeln('Результат: ',p,' ',q)
end.

Пример
Введите числитель и знаменатель: -210 165
Результат: -14 11
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?