Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
diana55665
03.11.2020 11:20 •
Информатика
Напишите программу (pascal) найти сумму вводимых с клавиатуры чисел, которые отрицательные.
Ответ:
rdutchik
05.10.2020 14:24
Program n1;
var sum,a: integer;
begin
sum:=0;
repeat
readln(a);
if a<0 then sum:=sum+a;
until (a=0);
writeln(sum);
end.
0,0
(0 оценок)
Ответ:
millkawow
05.10.2020 14:24
// PascalABC.NET 3.2, сборка 1385 от 14.02.2017
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('Сумма отрицательных чисел равна ',
ReadSeqRealWhile('Ввод завершайте нулём:',x->x<>0).Where(x->x<0).Sum)
end.
Пример
Ввод завершайте нулём: 2.5 -4 -6.25 5.143 11 -8 0
Сумма отрицательных чисел равна -18.25
0,0
(0 оценок)
Популярные вопросы: Информатика
pavlon4kp0bmeh
15.02.2022 23:15
ЭЕМ буыны термимінің анықтамас ...
Пам904
28.11.2022 21:43
Процессордың функциясы мен пайдаланушының іс-әрекетін сәйкестендір. Пернетақтадан сандық деректерді енгізу 0ОНәтиженің орындалуыАрифметикалық амалдарды қолданып,нәтижені есептеуC)АЛҚ...
den193p08o5z
26.08.2021 06:23
Кто напишет самую смешную шутку - получит...
Miratovich
14.02.2020 05:33
Расставь элементы в правильном порядке Восстанови вид алгоритмической конструкции цикла с заданным числом повторений. begin repeat until end to Кначальное_значение while оператор...
Стешулький361953
27.03.2023 04:15
Очень лёгкая контрольная по инфе...
mailrujl
14.11.2021 12:08
Написать программу в pascal. задан двумерный массив c из 3-х строк и 5-и столбцов. составить программу, которая вычисляет произведение всех элементов массива. затем организовать...
shukur3
07.11.2022 00:25
Выберите предметы или существа нарисуйте их и придумайте о каждом загадку заполните таблицы...
maks312017
03.02.2020 04:53
3. почему медицинские инструменты стерилизуют не путем промораживания, а кипячением или нагреванием в автоклавах при высоком давлении?...
Miky14
03.02.2020 04:53
Прист_жная в тройке(какую букву вставить в пропуск) и как доказать...
ZinW
03.02.2020 04:53
Осуществить цепочку превращений caco3-cao-ca(ho)2-ca(nao3)2-caco3-co2 ⇒ca2 надо!...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var sum,a: integer;
begin
sum:=0;
repeat
readln(a);
if a<0 then sum:=sum+a;
until (a=0);
writeln(sum);
end.
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('Сумма отрицательных чисел равна ',
ReadSeqRealWhile('Ввод завершайте нулём:',x->x<>0).Where(x->x<0).Sum)
end.
Пример
Ввод завершайте нулём: 2.5 -4 -6.25 5.143 11 -8 0
Сумма отрицательных чисел равна -18.25