В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Kurakluk
Kurakluk
12.02.2020 09:17 •  Информатика

Написать программу в python программа просит ввести основание и прилегающую высоту треугольника, присваивает введённые значения переменным a и h, вычисляет площадь треугольника и печатает значения a, h и площади треугольника. вычисление площади треугольника оформлено в виде функции.

Ответ:
baryshevskayaam
baryshevskayaam
02.08.2020 21:22
# coding: utf-8
# Python 3.X

'''
Программа просит ввести основание
и прилегающую высоту треугольника,
присваивает введённые значения
переменным a и h, вычисляет площадь
треугольника и печатает значения
a, h и площади треугольника.
Вычисление площади треугольника
оформлено в виде вс
функции.
'''

def trig_area(a, h):
    a = 0.5 * a * h
    if a.is_integer():
        return int(a)
    else:
        return a

a = int(input('Введите основание: '))
h = int(input('Введите прилегающую высоту: '))
print('\nОснование: {}\nВысота: {}\nПлощадь: {}'.format(a, h, trig_area(a, h)))
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?