В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
AlisaBust
AlisaBust
28.05.2022 20:16 •  Информатика

Написать программу в pascal, которая вычисляет среднюю оценку за неделю (с массивов)

Ответ:
Оленка124683
Оленка124683
05.10.2020 14:06
//PascalABC.Net
begin
var a: array of integer;
setLength (a, readinteger('Введите кол-во учеников: '));
for var i:=0 to length(a)-1 do a[i]:=readinteger ('Введите оценку ученика: ');
write ('Средняя оценка: ', a.Average);
end.
0,0(0 оценок)
Ответ:
Meylisa3
Meylisa3
05.10.2020 14:06
Program n1;
const n=12;
var a: array[1..n] of integer;
i,sum: integer;
begin
randomize;
sum:=0;
write('оценки за неделю: ');
for i:=1 to n do
begin
a[i]:=random(4)+2;
write(a[i],' ');
end;
writeln;
for i:=1 to n do sum:=sum+a[i];
writeln('среднее арифмитическое: ',sum/n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?