В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
наира203
наира203
11.12.2021 14:24 •  Информатика

Напишите программу, которая удаляет из строки все повторяющиеся символы. входные данные на вход программы подаётся строка, содержащая символы таблицы ascii. выходные данные программа должна вывести исходную строку, из которой удалены все повторяющиеся символы. примеры входные данные abc13a1b2z3c выходные данные abc132z входные данные qwasd123 выходные данные qwasd123 pascal abc 1.8

Ответ:
ubbdfqhdu
ubbdfqhdu
05.10.2020 13:39

var str:string;i,n:integer;

begin

readln(str);

for i := 1 to length(str)-1 do

for n:=length(str) downto i+1 do

if str[n]=str[i]then delete(str,n,1);

writeln(str);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?