В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
furymalice
furymalice
05.05.2023 02:45 •  Информатика

Напишите программу, в которой пользователь вводит 5-тизначное число, а программа выводит 5-тизначное число-перевертыш. на языке пасхаль

Ответ:
ввіна
ввіна
05.10.2020 13:27
Var a,a1,a2,a3,a4,a5,b:integer;
begin
write('a = ');
readln(a);
a1:=a div 10000;
a2:=a div 1000 mod 10;
a3:=a div 100 mod 10;
a4:=a mod 100 div 10;
a5:=a mod 10;
b:=a5*10000+a4*1000+a3*100+a2*10+a1;
writeln('b = ',b);
end.

Пример:
a = 13524
b = 42531
0,0(0 оценок)
Ответ:
ВыберитеНик976476
ВыберитеНик976476
05.10.2020 13:27
Так как язык программироваия ты не написал, дам ответ на Си++, в данном примере от чистого Си отличается только вводом выводом (cin,cout-scanf,printf)
Решение:
#include "stdafx.h"
#include <iostream>
using namespase std;
int main()
{
setlocale(0,"");
int A[5];
cout<<"Введите пятизначное число, разделяя каждую цифру пробелом"<<endl;
for(int i=0;i<5;i++)
{
cin>>A[i];
}
cout<<"Перевёрнутое число:"<<endl;
for(int i=4;i>=0;i--)
{
cout<<A[i];
}
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?