В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
temik2005ap08ttx
temik2005ap08ttx
15.11.2022 02:04 •  Информатика

Написать программу, которая определяет в одномерном массиве, заполненном случайным образом, количество элементов, значения которых меньше числа, введенного с клавиатуры. если есть, то вывести эти элементы

Ответ:
laswsc11
laswsc11
05.10.2020 13:21
Program n1;
const n=17;
var a: array[1..n] of integer;
i,c,k: integer;
begin
randomize;
write('введите число: ');
readln(c);
writeln('массив: ');
for i:=1 to n do
begin
a[i]:=random(50);
write(a[i],' ');
end;
writeln;
writeln('эл. которые меньше ',c);
for i:=1 to n do if a[i]<c then
begin
k:=k+1;
write(a[i],' ');
end;
writeln;
writeln('количество: ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?