В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Варёна
Варёна
13.04.2023 05:59 •  Информатика

Pascal abcнапишите программу, которая определяет правильность записи целого числа в восьмеричной системе счисления. формат входных данных на вход программы поступает символьная строка. формат выходных данных программа должна вывести ответ 'yes', если строка представляет собой правильную запись целого числа в восьмеричной системе счисления, и 'no', если запись ошибочна.

Ответ:
nebylobyagjjhgf
nebylobyagjjhgf
05.10.2020 12:58
Var value, error: integer;
begin
var s:=readstring ('Введите строку: ');
val (s, value, error);
if (error<>0) or ('9' in s) or ('8' in s) then write ('NO') else write ('YES');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?