В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
egorsinitsyn9Egor
egorsinitsyn9Egor
19.04.2023 03:14 •  Информатика

Pascal с двумя 1. составьте программу, вычисляющую сумму квадратов всех чисел от 1 до n 2.напишите программу, определяющую сумму всех нечетных чисел от 1 до 99

Ответ:
NamaruC3
NamaruC3
05.10.2020 12:41
// PascalABC.NET 3.2, сборка 1383 от 09.02.2017
// Внимание! Если программа не работает, обновите версию!

Задача 1
begin
  Writeln('S=',Range(1,ReadInteger('N=')).Sum(x->x*x))
end.

Пример
N= 10
S=385

Задача 2
begin
  Writeln('S=',Range(1,99,2).Sum)
end.

Результат
S=2500
0,0(0 оценок)
Ответ:
guskovzahar2011
guskovzahar2011
05.10.2020 12:41
1.
var n,i:integer;
begin
readln(n);
for i:=1 to n do writeln(i*i);
end.
2.
var n,i:integer
begin
for i:=1 to 99 do
if i mod 2 = 1 then n+=i;
writeln(n)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?