Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Alevtinka28
07.05.2022 21:36 •
Информатика
Вычислить: 1+2+4++256 в паскале распишите программу !
Ответ:
degtyarenko1999
05.10.2020 12:05
Var i,s: integer;
begin
i:=1; s:=0;
repeat
s:=s+i;
i:=i*2;
until i>256;
writeln('s = ',s);
end.
второй вариант:
var s: integer;
begin
s:=1 shl 9 - 1;
writeln('s = ',s);
end.
s = 511
0,0
(0 оценок)
Популярные вопросы: Информатика
ArbuzovAndrey
06.01.2022 11:55
Цикл с предусловием. Урок 1 Дан фрагмент кода программы.Определи, какое число нужно поставить вместо многоточия, чтобы цикл выполнился ровно 3 раза.3465...
ganievadiyana
31.01.2021 13:53
Информатика решите под А и Б...
tema10112009
18.08.2020 21:31
напишите программу которая вычисляет и выводит среднее арифметическое значение для нескольких целых чисел в языке пайтон...
abduabdu2015
01.12.2020 21:29
ВЫВЕСТИ 30 СЛУЧАЙНЫХ ЧИСЕЛ ИЗ ДИАПАЗОНА (-20;20), ПОСЧИТАТЬ КОЛИЧЕСТВО ЧИСЕЛ ДЕЛЯЩИХСЯ НА 5 И СУММУ ЧИСЕЛ, ДЕЛЯЩИХСЯ НА 10. ВЫПОЛНИТЬ В ПАСКАЛЕ ABC...
Anastasya156
02.06.2021 11:18
Вычислить значения функций: F=3z-ln(xz)-2z²...
alenagerasimov1
07.05.2023 10:35
Самат с большим интересом прочитал роман шотландского писателя Роберта Стивенсона Остров сокровищ . Он тоже нашёл карту с указанием местоположения клада. Для поиска клада на карте...
vnigmatullina
08.06.2023 09:47
Представьте число 100001001110101 в двоично-десятичном коде....
dabby25
11.09.2022 17:08
Марата необходимо скачать из интернета звуковой файл небольшого размера ему выбрать формат файла. .jpq.pnq. avi.mp4.mp3...
nyarokhno
25.05.2021 15:23
Запишите код программы на языке Python: m=5n²+2/3n-2,5(n+5)...
dgamal05
25.04.2020 00:09
решить задачи по информатике. 1. Если первый ученик за 1ч может собрать М ведер яблок,2-й – К ведер, 3-й L ведер, то сколько ведер яблок они соберут за t часов? 2. Для изготовления...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
i:=1; s:=0;
repeat
s:=s+i;
i:=i*2;
until i>256;
writeln('s = ',s);
end.
второй вариант:
var s: integer;
begin
s:=1 shl 9 - 1;
writeln('s = ',s);
end.
s = 511