В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Kiki137
Kiki137
04.04.2021 15:27 •  Информатика

Написать программу в паскале: определить кол-во положительных и отрицательных элементов в каждом столбце массива a(n,m)

Ответ:
05NARIMAN05
05NARIMAN05
05.10.2020 10:59
// PascalABC.NET 3.2, сборка 1382 от 06.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество строк в массиве:');
  var m:=ReadInteger('Количество столбцов в массиве:');
  Writeln('*** Исходный массив [',n,',',m,'] ***');
  var a:=MatrRandom(n,m,-99,99);
  a.Println(4); Writeln(5*a.ColCount*'-');
  a.Cols.Select(x->Format('{0,4}',x.Where(y->y>0).Count)).Print('');
  Println(' - положительных');
  a.Cols.Select(x->Format('{0,4}',x.Where(y->y<0).Count)).Print('');
  Println(' - отрицательных');
end.

Пример
Количество строк в массиве: 5
Количество столбцов в массиве: 8
*** Исходный массив [5,8] ***
  32  83 -68 -33 -63  43   0  30
  81  46 -52  56  49  10 -31   9
 -41 -56 -80  70 -95  94 -53  56
   0 -87 -24  23 -54  24 -84  -3
  22  74  54 -98  42  94 -68  59

   3   3   1   3   2   5   0   4 - положительных
   1   2   4   2   3   0   4   1 - отрицательных
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?