В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
anastasiyachevh
anastasiyachevh
07.03.2023 04:08 •  Информатика

Уровень b. m. две одинаковые цифры рядом напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). входные данные входная строка содержит одно натуральное число. выходные данные программа должна вывести слово 'yes', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'no', если такой пары цифр нет. примеры входные данные 5221 выходные данные yes входные данные 1232 выходные данные no уровень c. o. две одинаковые цифры напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере две одинаковых цифры, возможно, не стоящие рядом (как, например, 212). входные данные входная строка содержит одно натуральное число. выходные данные программа должна вывести слово 'yes', если в числе есть две одинаковые цифры, и слово 'no', если такой пары цифр нет. примеры входные данные 212 выходные данные yes входные данные 12345 выходные данные no

Ответ:
Маря04
Маря04
05.10.2020 10:57
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
// Внимание! Если программа не работает, обновите версию!

Задача М

begin
  var a:=ReadInteger.ToString.AdjacentGroup;
  var f:=False;
  foreach var g in a do
    if g.Count>1 then begin
      Write('YES'); f:=true; break
    end;
  if not f then Write('NO')  
end.

Примеры
5221
YES

1232
NO

Задача О

begin
  var s:=ReadInteger.ToString;
  if s.Length<>(s.Distinct).Count then Write('YES')
  else Write('NO') 
end.

Примеры
212
YES

12345
NO
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?