В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
врондао
врондао
07.03.2023 04:08 •  Информатика

Написать программу по информатике! дана непустая последовательность целых чисел, оканчивающаяся отрицательным числом. верно ли, что все элементы последовательности равны между собой?

Ответ:
PineappleRomka
PineappleRomka
05.10.2020 10:56
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Длина последовательности: ');
  var a:=(SeqRandom(n-1,0,1)+(-1)).ToArray; // последовательность 0 и 1
  a.Println;
  if a.Where(x->x>=0).Distinct.Count>1 then
    Writeln('Есть отличающиеся элементы')
  else Writeln('Все элементы равны')
end.

Примеры
Длина последовательности:  4
1 1 1 -1
Все элементы равны

Длина последовательности:  5
0 1 1 0 -1
Есть отличающиеся элементы
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?