Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
вікуся40
22.05.2022 07:35 •
Информатика
Дано натуральное число n. составьте программу, которая выводит все числа от 1 по n, у которых последняя цифра кратная 3
Ответ:
polinakarpenko3
05.10.2020 10:20
Var
n,d:integer;
f:Text;
begin
Assign(f,'input.txt'); Reset(f);
Read(f,n);
Assign(f,'output.txt'); Rewrite(f);
d:=n mod 10;
while n>=10 do n:=n div 10;
if n>d then Writeln(f,'>')
else
if n=d then Writeln(f,'=') else Writeln(f,'<');
Close(f)
end.
TXT
0,0
(0 оценок)
Ответ:
Caxapok24
05.10.2020 10:20
Var n, i: integer;
begin
i := 3;
while i <= n do
begin
write(i, ' ');
i := i + 10;
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Viktoria818
07.05.2023 16:47
Назови основные показатели погоды (их 4)...
megamerezhnikova
20.04.2021 06:16
Уравьи идут друг за другом по неровной лесной тропе. На их пути встречаются ямки, в которые могут провалиться несколько муравьёв. Когда ямка заполняется муравьями, остальные муравьи...
Runalbert
18.02.2021 04:59
Нарисовать картинку гриба в пайтон...
stozhok1998
11.10.2021 21:18
В языке запросов поискового сервера для обозначения логической операции «ИЛИ» используется символ «|», а для логической операции «И» – символ «&». В таблице приведены запросы...
Aleksiy69
26.11.2022 05:04
Написать программу на паскале: дана s круга. найти его диаметр d и длину l окружности, ограничивающей этот круг, учитывая, что l = π×d, s = π×d2(в квадрате) /4...
Какаяразницакто
14.08.2020 13:27
В10 кб сколько мб с5йчас тетрадь сдавать оаоа...
meteleva06
14.08.2020 13:27
Напишите программу, которая считывает одну строку, после чего выводит «мяу», если в введённой строке есть подстрока «кот», и «гав» в противном случае. пример 1 ввод вывод извините,...
morcowqwerty
14.08.2020 13:27
Напишите программу для вычисления и вывода на экран корней квадратного уравнения ax² + bx + c = 0. значения коэффициентов уравнения вводите в диалоговом режиме....
RimValeria
14.08.2020 13:27
Какие средства программно-аппаратного уровня защиты...
Вилка68762
14.08.2020 13:27
1. выполните подстановку операции так , чтобы равенство() or not ()= оказалось верным. 2.выполните подстановку операции так , чтобы (1 and =0 оказалось верным....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n,d:integer;
f:Text;
begin
Assign(f,'input.txt'); Reset(f);
Read(f,n);
Assign(f,'output.txt'); Rewrite(f);
d:=n mod 10;
while n>=10 do n:=n div 10;
if n>d then Writeln(f,'>')
else
if n=d then Writeln(f,'=') else Writeln(f,'<');
Close(f)
end.
TXT
begin
i := 3;
while i <= n do
begin
write(i, ' ');
i := i + 10;
end;
end.