В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
s2702e
s2702e
19.07.2022 19:03 •  Информатика

Составьте программу, которая определяет число разрядов заданного натурального числа n (подсказка: сколько раз должна выполняться n=n div 10, чтобы получилось n=0)

Ответ:
qwertyqwerty1233
qwertyqwerty1233
24.04.2020 14:55
Program n1;
var c: longint;
function ch(n: longint ): longint;
var i: longint;
begin
i := 0;
while n > 0 do
begin
n := n div 10;
i := i + 1
end;
ch:= i
end;
begin
write ('Введите число: ');
readln (c);
if c<0 then c:=abs(c);
writeln ('в этом числе ',ch(c),' разрядов ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?