В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ssha2
ssha2
06.09.2021 15:21 •  Информатика

Напишите программу, которая выводит все простые числа в диапазоне от k до n ( 2 ≤ k ≤ n ≤ 100000 ). pascal

Ответ:
manonako1
manonako1
05.10.2020 10:11
Var
 k,n,x,d: integer;

begin
 read(k,n);
 for x := k to n do
  if x mod 10 = 3 then
    begin
    d := 2;
    while x mod d <> 0 do d := d + 1;
    if x = d then write(x,' ');
    end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?