В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Ксения203
Ксения203
17.05.2023 21:31 •  Информатика

Напишите программу на языке программирования (или составьте алгоритм). подсчитать количество простых чисел в одномерном массиве размером n, состоящем из целых чисел, полученных случайным образом.

Ответ:
АлираПендрагон
АлираПендрагон
14.08.2020 18:17
//
Program n1;
function pr(a:longint):boolean;
var i:longint;
begin
if a<2 then pr:=false
else
begin
pr:=true;
for i:=2 to round(sqrt(a)) do
if a mod i=0 then pr:=false;
end;
end;
const n=15;
var a:array[1..n] of integer;
i,k:integer;
begin
randomize;
k:=0;
for i:=1 to n do a[i]:=random(100);
writeln('массив: ');
for i:=1 to n do write(a[i],' ');
writeln;
for i:=1 to n do
if pr(a[i]) then k:=k+1;
writeln('кол-во простых чисел: ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?