В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Yeger
Yeger
14.11.2021 07:49 •  Информатика

Написать программу которая будет вводить на экран данные всех студентов в виде таблицы, а затем в виде таблицы с названием напечатать анкетные данные студентов, получивших только одну тройку на сессии (в паскале, программа должна состоять из процедур )

Ответ:
danil24451
danil24451
05.10.2020 09:43
//PascalABC.NET 3.2 сборка 1318

type
  student=record
    FIO:string;
    age:integer;
    CountOf3:integer;
  end;

Const
  n=3;

Var
  ar:array[1..n] of student;

procedure reading();
Var
  i:integer;
begin
writeln('ФИО         |Возраст    | Количество троек');
for i:=1 to n do
  begin
    read(ar[i].FIO);
    write(' ');
    read(ar[i].age);
    write(' '); 
   read(ar[i].CountOf3);
   writeln;
  end;
end;

procedure writing();
Var
  i:integer;
begin
writeln('ФИО         |Возраст    ');
for i:=1 to n do
if ar[i].CountOf3=1 then write(ar[i].FIO,' ',ar[i].age);
end;

begin
reading;
writing;
end.
0,0(0 оценок)
Ответ:
danchikpozitiv
danchikpozitiv
05.10.2020 09:43
//прога на Pascal`e
const
size1 = 12; size2 = 12; size3 = 5;

surnames: array [0..size1-1] of string =
('Петров', 'Иванов', 'Рузвельт', 'Лежебокер', 'Тьюринг', 'Земляника', 'Пугачев', 'Бухаров', 'Путин', 'Куклачев', 'Герасимов', 'Михайлов');

names   : array [0..size2-1] of string =
('Петр', 'Иван', 'Франклин', 'Роман', 'Алан', 'Виктор', 'Дмитрий',  'Кузьма', 'Денис', 'Ахмед', 'Владимир', 'Станислав');

groups  : array [0..size3-1] of string =
('Историки', 'Археологи', 'Филологи', 'Математики', 'Ораторы');

type marks = record
m2, m3, m4, m5: byte;
end;

student = record
Surname: string[20];
name: string[20];
group: string[20];
GR: integer;
mark: marks;
end;

var
i: byte;
stud: array of student;

procedure randomSTUD ();
var i: byte;
begin
randomize;

setLength (stud, random(30)+1);
for i:=0 to length (stud)-1 do
begin
stud[i].Surname:=surnames[random (size1)];
stud[i].name:=names [random (size2)];
stud[i].group:=groups [random (size3)];
stud[i].GR:=1999 - random (6); 
stud[i].mark.m2:=random (3); 
stud[i].mark.m3:=random (3); 
stud[i].mark.m4:=random (3); 
stud[i].mark.m5:=random (3);
end;
end;

procedure writeofSTUD ();
var i: byte;
begin
writeln ('Студентов: ', length(stud));
for i:=0 to length (stud)-1 do
begin
writeln ();
writeln ('');
writeln ('Студент №', i+1);
writeln ('Фамилия: ', stud[i].Surname);
writeln ('Имя: ', stud[i].name);
writeln ('Группа: ', stud[i].group);
writeln ('Год рождения: ', stud[i].GR);
writeln ('Оценки: ');
writeln ('Кол-во двоек: ', stud[i].mark.m2);
writeln ('Кол-во троек: ', stud[i].mark.m3);
writeln ('Кол-во четверок: ', stud[i].mark.m4);
writeln ('Кол-во пятерок: ', stud[i].mark.m5);
end;
end;

begin
randomSTUD;
writeofstud;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?