Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
sonex008
07.07.2020 17:41 •
Информатика
Turbo pascal : ввести фио как строку.определить количество вхождений символа а и длину введенной строки. удалить из неё все символы в,перед которыми находится символ о.
Ответ:
Kетушка9
05.10.2020 09:40
{на free работает!}
var
sur, sur1: string;
i, count, pz: byte;
begin
write ('Введите строку: ');
readln (sur);
for i:=1 to length (sur) do
if sur[i] = 'a' then inc (count);
writeln ('Длина строки : ', length(sur), ' символов; кол-во "а": ', count);
sur1:=sur;
for i:=2 to length (sur) do
if (sur[i] = 'b') and (sur[i-1] = 'o') then
begin;
delete (sur1, i-pz, 1);
inc (pz);
end;
write ('Удалено ', pz, ' "b"; Новая строка: ', sur1);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Коля12Коля
16.06.2022 18:01
4. Посмотрите на рисунок и выберите инструмент Ведение, который поворачивает объекты в определённом направленииаb)с)d)- а-b-d...
laskovetsigor2
03.02.2020 08:16
3. На какие виды делятся в программе SketchUp Make? У МЕНЯ САМОСТОЯТЕЛЬНАЯ ...
alinodhakota
14.04.2023 23:44
Сопоставьте программный код и результат....
IvIeIrIoInIiIkIa
10.03.2021 06:26
Задание 1 1.1 Рассмотрите следующую таблицу: В ячейку D1 введена формула =$А$1*2+C1/1. a) Запишите элемент формулы, который содержит относительную ссылку. ………[1] b) Запишите...
swevkukviktor
31.01.2022 08:35
Имеется функция . Составьте программу нахождения значения функции для значений х и у, вводимых с клавиатуры....
dasha00200100
13.02.2023 02:06
8. В кодировке кои-8 каждый символ кодируется 8 битами. Паша написал текст (в нём нет лишних. пробелов):«Акн, Бали, Банда, Сибуян, Камотес, Лабрадор, Линкольна — моря».Ученик...
Fela06
04.09.2021 06:16
Для того, чтобы фрагменты рисунка, не перекрывали друг друга, нужно применить к фрагменту рисунка команды AВыделить- Повернуть BВыделить - Копировать - Вставить CВыделить -...
00LenaVaganova11
29.12.2020 06:34
Задачи: 1. Вывести на экран строковый рисунок (Рис. 1). 2. Написать программу, которая рисует пингвина (рис.2) 3. Написать программу, которая выводит следующий рисунок (рис.3)...
tyy6
29.10.2022 02:20
[за спам сразу бан] Программа должна : из двух чисел с разной четностью вывести на экран нечетное число ( ОБЯЗАТЕЛЬНО ИСПОЛЬЗОВАТЬ УСЛОВНЫЕ ОПЕРАТОРЫ then else...
ismail00
11.07.2020 16:55
Перечислите, любые три элемента форматирования данных в текстовом редакторе...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
sur, sur1: string;
i, count, pz: byte;
begin
write ('Введите строку: ');
readln (sur);
for i:=1 to length (sur) do
if sur[i] = 'a' then inc (count);
writeln ('Длина строки : ', length(sur), ' символов; кол-во "а": ', count);
sur1:=sur;
for i:=2 to length (sur) do
if (sur[i] = 'b') and (sur[i-1] = 'o') then
begin;
delete (sur1, i-pz, 1);
inc (pz);
end;
write ('Удалено ', pz, ' "b"; Новая строка: ', sur1);
end.