В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
М4ш4
М4ш4
17.03.2021 09:49 •  Информатика

2. составьте программу для нахождения количества литров l, которое содержится в x галлонах (1 галлон = 4,54609 литра). исходное количество галлонов задается с клавиатуры. 3. напишите программу вычисления общего члена bn и суммы sn первых n членов прогрессии. первый член прогрессии b1, знаменатель прогрессии q и число членов с клавиатуры.

Ответ:
katyaaalovely
katyaaalovely
05.10.2020 09:18
//PascalABC.NET 3.2 сборка 1318

Const
  gal=4,54609;

  Var
  x:real;
begin
readln(x);
writeln(x*gal);
end.

//2

Var
  b1,q:real;
  n:integer;
begin
readln(b1,q,n);
if (b1=0) or (q=0) then
  begin
    writeln('b1=0 or q=0');
    exit;
  end
else
if q=1 then
   begin
    writeln('Sum=',b1*n);
    writeln('Bn=',b1);
  end
 else
 begin
  Writeln('Sum=',b1*(1-power(q,n))/(1-q));
  Writeln('Bn=',b1*power(q,n-1));
 end;
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?