В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
karina847
karina847
12.05.2022 09:49 •  Информатика

Написать программу перевода из десятичной системы счисления в двоичную при функций пользователя. паскаль(функции пользователя).

Ответ:
Ксения0112387
Ксения0112387
05.10.2020 09:12
Program n1;
var n: integer;
function per(n: integer ): integer;
var
a: array[1..500] of integer;
i,c:integer;
begin
c:= 0;
repeat
c:= c + 1;
a[c]:= n mod 2;
n:= n div 2;
until n = 0;
for i:= c downto 1 do
write(a[i]);
end;
begin
write('введите число: ');
readln(n);
per(n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?