В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Kikikki
Kikikki
22.04.2022 19:36 •  Информатика

1)составьте программу сумму и разность целых чисел a и b.2)составьте программу нахождения первой цифры двухзначного числа а.3) составьте программу вычисление суммы двузначного числа а.4) составьте программу вычисления суммы цифр трехзначного числа а. это разные

Ответ:
lerusik112
lerusik112
05.10.2020 08:17
1)
var a,b:real;
begin
readln(a,b);
writeln('А-Б=',a-b);
writeln(А+Б=',a+b);
end.
2)
var a:string;
begin
readln(a);
write(copy(a,0,1);
end.
3)
var a,s1,s2:string;
begin
readln(a);
s1:=copy(a,0,1);
s2:=copy(a,1,1);
write('Сумма цифр числа',a,'=',s1+s2);
end.
4)
var a,s1,s2,s3:string;
begin
readln(a);
s1:=copy(a,0,1);
s2:=copy(a,1,1);
s3:=copy(a,2,1);
write('Сумма цифр числа',a,'=',s1+s2+s3);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?