В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
777alisham
777alisham
09.07.2020 09:04 •  Информатика

Составьте программу в паскале заполнить массив а пятью произвольными целыми числами. изменить каждый элемент массива так, чтобы он был умножен на свой порядковый номер. исходный и полученный массив вывести на экран. пример: исходный массив: 2 6 8 9 12 полученный массив: 2 12 24 36 60

Ответ:
katystolbova
katystolbova
05.10.2020 07:49
Для случайных чисел:

var
   a: array[1..5] of integer;
   i: integer;
begin
   randomize;
   for i:=1 to 5 do
      a[i] := random(100);
   for i:=1 to 5 do
      write(a[i], ' ');
   writeln;
   for i:=1 to 5 do
      a[i] := a[i] * i;
   for i:=1 to 5 do
      write(a[i], ' ');
end.

Для ручного заполнения:

var
   a: array[1..5] of integer;
   i: integer;
begin
   for i:=1 to 5 do
      readln(a[i]);
   for i:=1 to 5 do
      write(a[i], ' ');
   writeln;
   for i:=1 to 5 do
      a[i] := a[i] * i;
   for i:=1 to 5 do
      write(a[i], ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?