В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
antiangel18
antiangel18
01.02.2022 12:46 •  Информатика

Напишите программу, которая вводит два вещественных числа, a и b ( a < b ), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) . входные данные входная строка содержит два вещественных числа a и b , разделённых пробелом. гарантируется, что a < b . выходные данные нужно вывести в одной строке через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) с тремя знаками в дробной части.

Ответ:
natalya180000
natalya180000
05.10.2020 07:48
Program helpglupshkolnikam;
uses crt;
var a, b: real; i: integer;
begin  
randomize;  
readln(a,b);  
for i:= 1 to 5 do    
write(' ',(Random()*(b-a)+a):0:3, ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?