В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nargizcavid
nargizcavid
06.01.2023 20:34 •  Информатика

Требуется написать программу на c++ даны натуральные числа n и m (0≤m≥9). найти сумму первых m цифр числа n. если цифр в n меньше, чем m, то считать недостающие цифры равными 0.

Ответ:
дзхен
дзхен
20.08.2020 12:29
#include <iostream>
using namespace std;

int main()
{
    int n, m, n1;
    int s=0;
    int k=0;
    cout << "n = ", cin >> n, cout << "\n";
    cout << "m = ", cin >> m, cout << "\n";
    n1 = n;
    while (n1 > 0){
    s += n1 % 10;
    n1 = n1 / 10;
    k++;
    }
    n1 = n;
    for (int i=1; i<=k-m; i++) {
    s -= n1 % 10;
    n1 = n1 / 10;
    }
    cout << "s = " << s << "\n";
    return 0;
}

Пример:
n = 34568
m = 4
s = 18
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?