В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
polinakolesnik4
polinakolesnik4
06.09.2022 22:53 •  Информатика

По составить программу с дан целочисленный массив с числом элементов n и вывести из него нечетные элементы и их сумму. в паскале а если еще можно то блок схему)

Ответ:
Люська5612
Люська5612
26.08.2020 07:25
Program mas;
const n=4; // число элементов
var a: array [1..n] of integer; //массив
i, sum: integer; //переменные
begin //начало
sum:=0; // сумма=0
for i:=1 to n do readln(a[i]); //вводим массив
for i:=1 to n do //цикл
if(a[i] mod 2 <>0) then //условие нечетности
begin
writeln(a[i]); //выводим нечетные
sum:=sum+a[i]; //считаем сумму
end;
writeln(sum); //выводим сумму
end. //конец
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?