В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sofiaryzhova
sofiaryzhova
01.05.2023 04:59 •  Информатика

Верно ли, что сумма всех отрицательных членов заданного массива по модулю больше, чем сумма всех положительных членов. составить программу

Ответ:
kattya100
kattya100
05.10.2020 06:51
Const n=10; 
var a:array[1..n] of integer;
i,s1,s2:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(51)-25;
 write(a[i]:4);
 end;
writeln;
s1:=0; s2:=0;
for i:=1 to n do
 if a[i]<0 then s1:=s1+a[i] else s2:=s2+a[i];
writeln('s1 = ',s1,' s2 = ',s2);
if abs(s1)>s2
 then writeln('Yes, |',s1,'| > ',s2)
 else writeln('No, |',s1,'| <= ',s2);
end.

Пример:
Массив A:
  -3  16   5 -14 -14  -4 -13 -25  13  16
s1 = -73 s2 = 50
Yes, |-73| > 50
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?