В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Sabinaaa33
Sabinaaa33
01.05.2023 04:59 •  Информатика

Взаданном массиве вычислить среднее арифметическое значение элемента массива. зарание составить программу )

Ответ:
millergil
millergil
05.10.2020 06:52
Const n=10; 
var a:array[1..n] of integer;
i,s:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(51)-25;
 write(a[i]:4);
 end;
writeln;
s:=0;
for i:=1 to n do s:=s+a[i];
writeln('среднее арифметическое элементов массива = ',s/n);
end.

Пример:
Массив A:
   4 -25  -8  17   1  15 -23 -13  16 -22
среднее арифметическое элементов массива = -3.8
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?