Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
насьть
07.04.2023 17:25 •
Информатика
Дано натуральное число n,составить программу,котоая выводит на экран все натуральные числа,квадрат которых не больше чем n
Ответ:
Alisa45612
26.08.2020 07:10
Var n,i:integer;
begin
write('n = ');
readln(n);
i:=1;
while i*i<=n do
begin
write(i,' ');
i:=i+1;
end;
writeln;
end.
Пример:
n = 30
1 2 3 4 5
0,0
(0 оценок)
Популярные вопросы: Информатика
Kisylyaaa
30.04.2021 05:36
Pascalabc 40 ! 1) дан линейный массив a[1..n], содержащий целые числа. вычислите сумму нечетных чисел и распечатать номера таких чисел. 2) дан линейных массив [1..n], содержащий...
4553234
26.09.2021 22:42
Объясните назначение условного форматирования электронной таблице...
alinakuzmich324
13.01.2022 02:00
Даны три числа a b c необходимо вычислить и вывести на печать все числа больше пяти...
roker62
13.01.2022 02:00
Составить программу вычисления модуля числа с витвлением....
Aidanа1307
03.05.2023 04:07
Напишите алгоритм цифры 1, с вектором....
SuperMine
03.05.2023 04:07
Рисунок размером 512 на 256 пикселей занимает в памяти 80 кбайт (без учёта сжатия). найдите максимально возможное количество цветов в палитре изображения....
AliceКрошка
26.01.2020 21:11
Какой минимальный объём памяти (в кбайт) нужно зарезервировать, чтобы можно было сохранить любое растровое изображение размером 512×256 пикселов при условии, что в изображении...
Rin1111
14.08.2021 07:49
1дано трехзначное число. определить какая из его цифр больше первая или вторая. 2 дано четырехзначное число. определить кратна ли 3 сумма его цифр. это по информатике. в...
lanaruden
25.11.2022 00:16
Вс алгоритм вызывает самого себя 7 раз, запишите номер вызова данного вс алгоритма, который закончит выполняться последним ...
Dan4ikFun4ik
16.08.2020 05:52
Информатика 10 класс. Значение арифметического выражения:81^5+3^30-27 записали в системе счисления с основанием 9. Сколько цифр 8 в этой записи?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
write('n = ');
readln(n);
i:=1;
while i*i<=n do
begin
write(i,' ');
i:=i+1;
end;
writeln;
end.
Пример:
n = 30
1 2 3 4 5