В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
можской
можской
01.10.2021 16:56 •  Информатика

Написать программу, определяющую (отвечающею на вопрос) - больше ли числа х сумма цифр введённого числа

Ответ:
gabpara007
gabpara007
24.04.2020 03:58
Var a,b,x,s:integer;
begin
write('a = ');
readln(a);
write('x = ');
readln(x);
b:=a;
s:=0;
while b>0 do
 begin
 s:=s+b mod 10;
 b:=b div 10;
 end;
writeln('s = ',s);
if s>x
 then writeln('Сумма цифр больше ',x)
 else writeln('Сумма цифр не больше ',x);
end.

Пример:
a = 31854
x = 15
s = 21
Сумма цифр больше 15
0,0(0 оценок)
Ответ:
агамтасия
агамтасия
24.04.2020 03:58
#include <iostream>
#include <stdlib.h>
using namespace std;

int main() {
    int a,x,s=0;
    cin >> a >> x;
    for(;abs(a)>0;s+=abs(a)%10,a/=10);
    cout << (s > x ? "more" : "not more") << endl;   
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?